Overview
 Top Next
FTP Synchronizer is a FTP file sync product that allows you to synchronize files between local computer and remote FTP server
  • If you are a webmaster, do you still pick up all updated web pages manually and upload them one by one? You really need this product to update web sites. You just focus on your own job, FTP Synchronizer will detect all changed web pages and upload them for you by a single click!
  • If you want to backup files to an FTP server, FTP Synchronizer definitely can help you. It has multiple threads file transferring engine to speed up the sync process. Save plenty of valuable time for you!
  • If you simply need FTP sync functions, no need to look elsewhere anymore. You have got the best!

The basic features of FTP Synchronizer
  • Command line support
Easy to integrate FTP Synchronizer with your business; Or, use your favorite scheduler, e.g. Windows Scheduler, to automate FTP sync. You can also run FTP Synchronizer as service
  • Multiple threads file transferring
Uploading/downloading many files at the same time. Save plenty of time.
  • Detects conflict
How about if you modified a same file in both local and remote computer? Most software can NOT handle this, they simply overwrite older files with newer. Please, don't do this! FTP Synchronizer takes care this situation. You can ensure your files will not be overwritten by mistakes!
  • Inclusion/Exclusion filters
Only synchronize necessary files
  • Supports both non-security and security connection. Like SFTP, SSL etc.
  • Supports proxy/firewall
SOCKS4, SOCKS5, HTTP Proxy, Simply Relay, SOCKS4A, SITE hostname, OPEN hostname, USER user@host. etc
  • Priority list. Lets you control which files should be synchronized first
  • And much more...


How to prevent FTP Synchronizer from updating unchanged files?
 Previous Top Next
If you are new to FTP Synchronizer, you will find out that FTP Synchronizer wants to update all files at the first running even if you just upload/download these files, and they are not changed. This because that FTP Synchronizer need to retrieve the file attributes for future usage. Here is what you can do in this case:

If there are only a few of files. You can simply let FTP Synchronizer update these files again. But if you don't want to do so, please refer to following section:

1) Preview the profile. You'll find out that FTP Synchronizer want to update all files.
2) Please press 'Ctrl+A' to select all files in the file queue. Then, right click the mouse, select 'Mark as Unchanged' menu item. You will see that that 'action' column of all files changed to 'Mark as unchanged'.
3) Click 'Run' button to run the profile. FTP Synchronizer will update the file status and will not upload or
download any files at this time. This process is very quick and only takes you several seconds.
These files will be updated correctly if they are changed later.


How to run FTP Synchronizer from command line?
You can run FTP Synchronizer from command line. It's ideal if you want to schedule FTP Synchronizer or integrate FTP Synchronizer with you business workflow. It's easy to do so.

For example:
ftpsynchronizer.exe /RUN /PROFILE:"Profile 1" /PROFILE:"Profile 2" /NOLOG
As you saw, there only two types of parameters:
1) /PROFILE:"<profile-name>"
It means that which profile you want to run. You can specify multiple profiles. FTP Synchronizer will execute them one by one

2) /NOLOG
As there is no UI to show the status of profile. FTP Synchronizer enables the log file as default even if the log of the profile is disabled. You can specify this switch if you really don't need the log.

3) /RUN
As default, FTP Synchronizer only validate the command line parameters and preview the profiles. To run profiles, you need to specify this parameter.

Remarks:
1) The profile name is case insensitive
2) You need to enclose the profile with quotation marks
3) The parameters NOLOG, PROFILE and RUN must be capital

Some examples:
ftpsynchronizer.exe /RUN /PROFILE:"Profile 1"
Run "profile1" and save the log

ftpsynchronizer.exe /RUN /PROFILE:"Profile 1" /PROFILE:"profile 2" /NOLOG
Run "profile1" and "profile 2" orderly, didn't save profile log.

Here is a flash tutorial of Windows Task Scheduler if you are not familiar with it.


How to run profiles automatically, e.g. every a few of minutes?
Thanks to the 'command line' supporting of FTP Synchronizer. You can run FTP Synchronizer via any scheduler, e.g. Windows Task Scheduler, to automate the sync.

The detail information about command line parameters, please read this FAQ , there are only three parameters. Very easy!


How can I run FTP Synchronizer as a service?
The main reason to run FTP Synchronizer as a service is you can run the profiles even if you didn't login yet. As FTP Synchronizer supports command line, it's very easy to support service. For example, you can create a job by Windows Tasks Scheduler. Because Windows Scheduler runs as a service, it will launch FTP Synchronizer and run the profiles according to your settings.


How to use Inclusion and Exclusion filters?
FTP Synchronizer has a powerful inclusion/exclusion function. You can exclude all files with specified type regardless their location. Or, you can exclude specified files under specified folder. The wildcards also supported. Let's take following directory structure as an example:

/abc
/abc/a.txt
/abc/b.txt
/folder/abc
/folderb/def/abc
/folderb/def/xyz

1) How to exclude all 'abc' regardless the location?
Simply entering 'abc' as the exclusion filter. Then, '/abc', '/folder/abc' and '/folderb/def/abc' will be excluded

2) How to exclude 'abc' with specified location?
Simply entering the full path. For example, enter '/folder/abc' as exclusion filter will cause '/folder/abc' be excluded. But '/abc' and '/folderb/def/abc' will NOT


What's sync method?
Sync method defines "how to synchronize". Here are build-in sync methods:

1) Update remote files only
2) Update remote files and delete obsolete files from ftp server
3) Update local files only
4) Update local files and delete obsolete files from local computer
5) Bi-directional sync


Setup File Distribution
Does the setup file support command line, so I can install FTP Synchronizer via my script to automate the installation?

Yes, the setup program of FTP Synchronizer supports command line. You can use /VERYSILENT to disable installation progress window. There is no any messages during installing. For example: ftpsync-pro.exe /VERYSILENT


How can I share the configurations?
Sometimes, you may want to share the profiles with other users in the computer. So they don't need to create the same profiles again.

As default, FTP Synchronizer will read the configurations from 'C:\Documents and Settings\<login name>\Application Data\FTPSynchronizer'. This is the default option after installation. However, if the folder 'C:\Documents and Settings\all users\Application Data\FTPSynchronizer' exists, FTP Synchronizer will read all configurations from it. So, if you want to share the configurations, you can simply move the FTPSynchronizer folder from
'C:\Documents and Settings\<login name>\Application Data\FTPSynchronizer' to 'C:\Documents and Settings\all users\Application Data\FTPSynchronizer'.

Please notice that you may need the administrator right to access the all users folder.


How to export and import configurations
All configurations saved in
'C:\Documents and Settings\<login name>\Application Data\FTPSynchronizer'
or
'C:\Documents and Settings\All users\Application Data\FTPSynchronizer'

You may see three files in this directory:
Profiles.pg : It contains all profiles
accounts.ini : Account Manager configurations
config.ini : General configurations of your installation. e.g. Windows Location, Recent Items,etc.
  • If you want to backup all your configurations. Simply backup whole FTPSynchronizer directory.
  • If you want to share the profiles with other people, you can copy Profiles.pg and accounts.ini to him. The Config.ini is not necessary in this case.


Should I use Fast Sync?
If you want to update the remote files only and you will not modify the files by other software than FTP Synchronizer. Then you can use the Fast Sync option. It's very fast after the first sync.


How to update file time after sync?
You can update the last modification date after sync. You can change the settings in 'Profile Wizard->Advanced->File Transfer'. Please noticed that the FTP server must support MDTM command if you want to update the timestamp of remote file.

You can also set an offset hours if needed. It's useful if the local computer located in different time zone with FTP server.


How to use Dynamic Folder?
The Dynamic Folder means that you can put some marks to the path as the variable. FTP Synchronizer will replace them by the real value before sync. FTP Synchronizer supports following marks:

Mark Name | Explanation
%YEAR2% | Two digital year. For example: 07, 08
%YEAR4% | Four digital year. For example: 2007, 2008
%MONTH% | Use one digital for month when it less than 10
%MONTH2% | Always use two digital for month. For example: 01, 02, 10, 12
%DAY% | Use one digital for day when it less than 10
%DAY2% | Always use two digital for day. For example: 01, 02, 10
%HOUR% | Use one digital for hour when it less than 10
%HOUR2% | Use two digital for hour is possible. For example: 01, 02
%MINUTE% | Use one digital for minute when it less then 10
%MINUTE2% | Always use two digital for minute. For example: 01, 02, 10
%SECOND% | Use one digital for second when it less than 10
%SECOND2% | Always use two digital for second. For example: 01, 02, 10

You can put above marks to the profile folder. FTP Synchronizer will replace them as the real value before sync. For example, if the local path is C:\Source%YEAR%-%MONTH%- %DAY% and current date is 12/01/2007. Then, the real path will be C:\Source2007-12-1 when you run the profile.

Please notice that the marks are case sensitive.


How to register?
Thanks for your order, our payment service is powered by Plimus .
We accept following payment Options:Credit Cards, Wire Transfer, Phone, Fax, Mail/Check/Money Order, PayPal

Please visit our ordering page: http://www.ftpsynchronizer.com/order.php to place your order.

Within just a few of minutes after your purchase, you will receive a registration code and registration instructions by email from the address: sales@plimus.com. If you encountered any problems, please feel free to call us, we'll happy to assist you!
Phone Number: 866-312-7733 or 858-350-7473

If you want to buy more than 100 licenses, please contact our sales team . Thank you!
We also have 20% to 30% discount for educational purchases, please let us know if you would like to take this offer.


Contact us
 Previous Top
Fevosoft was founded in 2003. We focus on the development, marketing and support of file manipulation software. We combine the high-level skills and wide experience of our technical professionals with an efficient approach to the market. We work to solve the present-day needs of our customers by providing quality products and support services.

Contact our payment agent (Plimus)

Phone:
1-866-312-7733
1-858-350-7473

Fax:
1-858-777-5553

Mailing Address:
3830 Valley Center Dr. Suite 705-294
San Diego, CA 92130

Contact us

General and Support inquires:
Support: support@ftpsynchronizer.com

Marketing and Sales questions:
Sales: sales@ftpsynchronizer.com

Web site:
http://www.ftpsynchronizer.com